SmartGen | Common Fault & Solution of Genset Control System

SmartGen | Common Fault & Solution of Genset Control System

Q: Fault Symptom 1: Controller no water temperature/oil pressure/level, showing “####”.

 

A: Solution: Check controller temperature/oil pressure/level sensor and whether its “G” and “WK” is connected correctly.

 

Q: Fault Symptom 2: Controller displayed water temperature/oil pressure/level data is inaccurate. 

A: Solution: Check controller temperature/oil pressure/level curve type and whether it is matched with selected sensor.



Q: Fault Symptom 3: Controller displayed temperature/oil pressure/level data is unstable.

A: Solution:

1. Ground the common end of sensor on the controller to genset ground pile.

2. Check whether genset starter negative pole’s wire diameter is too thin causing voltage change in starting.

 

Q: Fault Symptom 4: Controller start output port is always burnt out.

A: Solution: Controller inner starting relay is small, its bearing current is limited; but genset starting current may be 2~3 times the relay bearing current. It can bear for a short time, but relay contact will be bonded if start repeatedly for a long time. So another relay should be added in starting.

 

Q:Fault Symptom 5: No start speed, no display or “0 rpm” display.

A:Solution: Check speed sensor and whether its screw-in position is too far from fly wheel; check wire connection and controller setting crank disconnect conditions.

 

Q: Fault Symptom 6: Genset no idle speed or over speed directly, controller issues “Over Speed Shutdown”.

A: Solution:

1.Check whether controller’s auxiliary output ports are configured;

2.Confirm genset using electronic speed adjusting or mechanical wire speed adjusting;

3.Check whether external connected electronic GOV has fault and its wire;

4.Check whether controller’s idle timing is “0s”;

5.Adjust electronic GOV’s rated speed, anticlockwise adjust it to drop speed.

 

Q:Fault Symptom 7: Genset cannot enter high speed, controller issues “Under Speed Shutdown”.

A:Solution:

1.Check whether controller’s idle control output port is disconnected in idle timing;

2.Check whether electronic GOV has fault and its wire;

3.Check whether electronic GOV’s rated speed is too low;

4.Check whether the speed raise time adjusting of electronic GOV is too large.

ブログに戻る